XB24 modem firmware update crash

Using the evaluation board XBIB-R-DEV board I tried to update the FW of a XBEE 24-ACI-001 modem with teh X-CTU software.
the procedure start well, but at the end the communication stop and the module continue to reset (the RESET pin continue to go down)

someone has an idea why?
and to recover the modem?


I have the same error, does any body knows how to solve it, please? If I found the solution i post it. Thanks. :slight_smile:

Hi again, I found a solution, i just download the most recent version of x-ctu ( in this moment) and the problem goes out!

Same happening here but just with 3 recently acquired modules. Other modules bought 1 year ago don’t suffer that issue.
I already downloaded X-CTU but there seems to be no way of bringing back the ‘fried’ modules.

Anyone has any idea on recovering/debricking this units?

Thanks in advance.

This would be a good issue to contact Technical Support about, in particular regarding the three radios exhibiting this problem. We can than investigate the issue more thoroughly and determine the cause.

This problem is the same I’ve having right now, I had done firware update in eight modules a year ago, but now during an updating it stops for something and now the module is useless.

I’m really worried, because I don’t want to buy a new Xbee cause I’m afraid to have the same problem.

DFB: I finally solved the problem on most units. After opening a support case, some indications from the support team that don’t appear to be clear enough in the documentation, helped me solve the problem.

First of all check if the problem is caused by wrong firmware version as it was in my case. My newer modules are revision B, and according to the changelog:

there are a lot of versions that don’t work properly with that revision of modules. Silly me, I didn’t check that and upgraded the modules with the same firmware I did my previous ones.

Please try this:
-Download and install latest X-CTU from the downloads section.
-Power off your module.
-Put reset to ground, or activate reset switch in your test board.
-While powered off (yes!) start the update on the x-ctu and wait until it complains that a reset is needed.
-Power on your board, and after a few seconds, release reset.
-Update should start ‘normally’.

Hope this helps you.
In case don’t, contact technical support, they quite solved the problem for me.

I get my Xbee-PRO back !!!

Because I always have had modules RevA I didn`t notice that: “Firmware versions 10A0 through 10A4 cannot run on Rev-B modules”, so I made the mistake of trying to update the 10A4 version, so the Xbee turn useless.

I recover it just doing the steps suggest by Kaneda (thanks a lot!!!) and writting on the module compatible versions like 1084 and 10A5.


I am a new bee on Maxstream.

Where can i get knowledge on revA, revB and revC modules & its compatibilty with the firmware versions?

Also, please mail me d firmware version 10A0, if u have. Will 10A0 work fine with revA modules?

Pls reply soon,



The bulk of the modules manufactured after 12/07 and all modules manufactured after Jun of 08 are rev B or above. These modules support firmware versions 1084, 10A5 and above.

Firmware version 10A0 was a beta version that is no longer available or supported and will not install on your new modules.

All older module will support all firmware versions.

Kaneda, you are a crack!!! )))) Thanks very much!!!


I have the same problem with my two Xbee.
The caracteristics of them are :

  • Xbee XB24-AUI
  • 802-15-4
  • 001-rev B

I use one adafruit adapter ( http://www.adafruit.com/index.php?main_page=product_info&cPath=29&products_id=126&zenid=50a0e2b2d9ec4375c42ce270568895bb) with an FTDI 3V3 cable ( http://www.adafruit.com/index.php?main_page=product_info&cPath=33&products_id=70&zenid=50a0e2b2d9ec4375c42ce270568895bb) and the last X-CTU soft.

At the begining, the two Xbee worked well without any bug. I have upgraded them with firmware 10E6 with no problem after this upgrade.

Later, I rewind to them and try to read the firmware and : nothing

The two doesn’t answer to any line command or read and write.

The baud rate is 9800-8-N-1.

I try “Tobrew” setting with no success.
I also try with a Reset wiring Reset pin to Ground. ( http://forums.digi.com/support/forum/printthread_thread,243_offset,0)

Nothing !!!

Here is two screen shoots of X-CTU software.

  1. PC Setting

  2. Modem Configuration

Do you have an idea ?

Thanks a lot,

Michel (From France)


i have same issue, my thread is the above link

my 3 radios in question: xb24-awi-001-revb

did have fw: 10cd -> 10e6

now none of them can i comm with using x-ctu