where can I download the firmware 10c8

Who can tell me where can I download the firmware 10c8?

You should be able to download it via X-CTU by choosing it as a menu option.

More importantly though, why would you want to do this? The fine folks at Digi have an excellent track record: the latest version is always the best. Don’t use an old version like 10c8 unless you really know why you need to use it.

Johnf brings up a good point. The 1xE6 firmware is available from link on this page: http://www.digi.com/support/productdetl.jsp?pid=3257&osvid=0&s=268&tp=1

My company just received many XBee USB Adapter S1 Pros and when I use the read function in the Modem Configuration tab of X-CTU I get a message that says “Modem Configuration file was not found. Would you like to check the website for updates?” Which I have done, but after updating ( yet again) X-CTU still can’t read the USB Adapter.

What version of X-CTU are you using?

Sorry for taking so long to respond another bonfire popped up. I am using the most current version

Try to reflash the XStick with new firmware version by selecting proper modem type in the modem configuration tab of X-CTU software.

As in checking the “always update firmware” box? I tried that, didn’t work

*edit: I am able to ‘always update the firmware’ to firmware version 10CD, but after that the USB Adapter seems to get ‘stuck’. If I try that with any other firmware version the attempt fails.

Hmm. Have you checked the FAQ - particularly question 11 point 2?

Or if that fails, does any of the other questions help?

SUCCESS!! 11.8 was the ticket, kinda. I reset the USB Adapter while XCTU was attempting to verify the firmware version and the download worked. I had a second USB Adapter in the same situation and the method worked on that Adapter as well. Thanks to everyone that helped.