Xbee module not responding for test/query

Hello to all,

      I  am using Xbee series2 module. i try to communicate with another same module, at that time i try to write an API into module but it shows "Writing failed" and then module is not communicate with X-CTU software.

I follow the reset methods available in forums but those are not working for me…anybody please tell me how to solve this problem…


hiii Try the following method… It will help you…

1.Connect the interface board to the computer via appropriate cable (USB or Serial) (If using Serial, connect power as well)

2.Make sure the XBee module is NOT plugged into the interface board

3.Open the X-CTU program and select the proper COM port.

4.The first screen you see in on the PC Settings tab. On this tab please change the baud rate to 38400 and put a check in the “No Baud Change” check box.

5.Navigate to the Modem Configuration tab

6.Select the proper modem type, function set and firmware version from the 3 drop down menus located about 1/3 of the way from the top of the window.

7.Click on the Show Defaults button and put a check in the “Always update firmware” check box.

8.Click on Write. (Yes, the module is NOT plugged in) An Action Required box will appear. This is good. When this happens, hold in the config/reset switch on the interface board and CAREFULLY plug in the module and then release the config/reset button.

9.You should now see that box disappear and a progress bar will appear along the bottom of the window. You will see the bar progress and then the box will appear again. This is good. Just hold in the reset switch on the interface board for about 1-2 seconds and then release. The box will disappear and the status at the bottom of the window will show that the write was complete.

10.Go back to the PC Settings tab and change the baud rate back to 9600 and uncheck the “No baud change” check box.

11.Click the “Test/Query” button. You should get a clean bill of health.