Interrupted reset leads to bricked XBee

So, I used to have a pair of XBee Pros, one on an XBIB-U-Dev Rev 3 board and the other on a XBIB-U-Dev Rev 4 board and could talk to both of them through X-CTU. I was in the middle of trying to get them to talk to one another (as they had been previously used and had some funky settings on them that wouldn’t even let X-CTU identify them and needed a factory reset) when I tried to restore the firmware settings on one, got a recurring listing of the firmware updates X-CTU had found for itself that seemed to be on a neverending loop, force-quit X-CTU, and now can’t get the program to do anything to the XBee on the Rev 3 board.

A factory reset doesn’t take and gives me this message back:

Getting modem type…Programming modem…Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Lost communication with modem
…Write Parameters…Failed

Not sure where to go from here…any ideas? Any help would be greatly appreciated.


You might be selecting wrong PC Baud Rate. Then try with changing PC Baud Rate. If you had not set default when writing the firmware again then try forcing the Function set and firmware again in the XBee.

How do I force a function set/firmware writing? I’m familiar with the factory reset procedure for the units, but that doesn’t work…so what’s this method?

I’ve tried changing the PC baud rate, but without success yet…I do have a couple of other combinations to try with it, though, so I’ll give it a few more shots.

Have you tried out the possibilities from the FAQ?