Can't reset Xbee

Just got a couple of new XBee’s. I tried to upload the Coordinator API to one of them and the sequence failed. After that the the X-CTU won’t find the device anymore. Ut asks me to reset it. So after looking at a few youtube videos I tried the same thing. I have the sparkfun FTDI so I tried connecting RST to GND. No go. I also tried connecting pins 5 and 10 on the back of the Xbee. Still no go!
Any advise?


Follow these recovery steps again after optimizing your USB setting.

Here is a great article about it:

Optimizing USB settings would work. I tried the same procedure and it worked for me.
If it doesn’t work, try the following steps.

Try to reflash the firmware using below steps

  • Change the baud rate to 38400 and check “No baud change” under PC Settings in X-CTU
  • Go to Modem Configuration tab, select correct Modem, Function set and Version
  • Click “Show Defaults”
  • Check “Always Update Firmware”
  • Click “Write”
    If “Action Required” window pop up, press the reset button on the interface board once, Digi interface provides reset button.
    I’m not sure about other boards. The pop up disappears and module gets programmed to selected firmware.
  • If you get any errors, like checksum error failed, you need to optimize your interface boards, refer the following link,
  • Now go to PC Settings and change the baud rate to 9600 and uncheck “No Baud Change”
  • Go to modem configuration tab and select Read, you can see all the XBee parameters.