Reflashing Failure XBee-PRO


I’m unable to reflash a new XBP24Z7 -004 RevB. I unfortunately installed the End Device DIO firmware. It installed OK and is now unusable.

I’ve tried doing the over the air reflash from your archive (Bootloader_to_force_XBee_reflash), but never get any response at all from the bootloader. What are my options from here?



Check out this procedure:

The DIO firmware lacks a serial port, thus XCTU cannot talk to it. OTA sometimes works (usually works) but it is never as predictable as direct wires :slight_smile:


Thanks for the reply. I’ve tried the OTA and it doesn’t respond at all. Never se the bootloader banner. Any other options?



Nothing but the bootloader - it can be fussy to use, with the timing fussy.

One thing I have seen is

  1. I try the proceddure, but do NOT see the menu
  2. don’t touch any hardware - no reset
  3. Ignore this, with baud rate still at 115k, go back to the normal “Modem Confuguration” and try the ‘Write’ with ‘Always update Firmware’ checked and you will see in the text area near the bottom something like “Detected active bootloader …”

So it seems at times you fail to see the message, but the Ember chip still has fliped into bootloader mode.

Also try reflashing in the API Coordinator firmware first. It is probably my imagination, but it seems to be the most ‘robust’ to reflash. Avoid trying to reflash as an ‘End-Device’ only firmware as those seem the least robust. Like I said, may be my imagination, but once the API-coordinator fw is in, just set the baud rate back to 9600 with API Enabled checked and you should be able to change to the desired final fw.

I have the same problem with XBP24-Z7WIT-004 rev H.
I’ve reviewed the procedure and doing your indications but I haven’t had luck…
I have downloaded all the newest firmware versions, but I am not sure to have the proper fw… I have as fw XBP24BZ7…Is that correct for my modem?
Many thanks!

I am experiencing the same problems, with A XBP24BZ7UITB003 -revF.
I have used the
procedure on standard XBee’s with success. in the terminal window I get no menu just a dot and a dot after the B. It is a new part and I have had no success with x-ctu at all. Could it be a pwoer issue? I’m using a Sparkfun USB card for my “flash station”

I follow the instructions but when I type B nothing happens.

I’m looking for a bootloader replacement. Is it possible on XBee Pro S2?