Connection Problem after failed flashing

I’ve got a ‘small’ question about my XBee’s. I have here two various devices. First is working with ZigBee, second with ZNet 2.5. I tried to establish a conncection so that they can talk to each other, but it didnt worked. If I connect to the ZNet one with XCTU, I can chose between ZNet 2.5 and ZigBee to flash. The ZigBee one just show ZigBee versions. So I flashed the ZNet one with ZigBee (API)…and now I can’t communicate anymore via UART (XCTU). In addition, the process aborted because of an (communication?)error. But with a wireless network analyser, I still see beacon requests flying around, so the XBee isn’t broken. I have asked google for information and I tried some possible solutions…like a manual reset before flashing and so on, but nothing worked. After this I attached a network analyser at the Rx and Tx pin of the XBee, to see what happend if I try to communicate from XCTU to the XBee. Very interesting: the Rx line shows the sended information from XCTU after clicking ‘Test/Query’. The Tx line is dead and nothing happend there, also if I reset the Xbee device. I tried the other Xbee and had a look, whats happening there at ‘Test/Query’. Here I sore a answere from the device.

So my problem is: I flashed ZigBee(API) on a device which was inteded for ZNet 2.5 and now I can’t communicate via UART anymore. Also I tried every Baudrate configuration, but nothing works.

Is there any way to solve this problem? I would be glad if you can help me.

Best regards


Did you enable API under the PC setting tab in x-ctu?

Yes, of course :slight_smile: I tried even every possible baud rate with any possible option combination of ‘API’ and ‘Use escape characters’ but it still won’t work.

A check at ‘Always update firmware’ didn’t work, too.

best regards


The best way to resolve the issue at hand is to upgrade the firmware on your Znet 2.5 modules to the current ZB firmware versions. You can see how to do this by going through the Znet 2.5 to ZB migration document locate at I would also recommend using the steps outlined at to reload the radios firmware with.

Thanks for your fast response. But unfortunately these two manuals doesn’t work, too. Every time when I try this, I get the following error message (in api mode):

Getting modem type…OK
Programming modem…Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Lost communication with modem
Write Parameters…Failed

However this is a more specific message as I got before:
Getting modem type…OK
Lost communication with modem
Write Parameters…Failed

But I observed another interesting point by trying this new manuals:
I get this new error message at any baudrate configuration, too. And as I tried to flash the ZigBee software I didn’t changed the baudrate setting, so normally it should be 9600-8-N-1 furthermore. In addition, when I turn off the API connection mode, I don’t get that message (that I have to power off the device press reset and so on)…just the second error message above. Also strange: When I get this message (power off, press reset etc.) and I just reconnect the power supply, he tries to flash again, too…but like I said, every time same error message (so independend from the reset button).

Any more ideas? :slight_smile:

best regards

When I had a failed flashing of an XBee Pro (XBP24-B), it would no longer respond to the X-CTU program or anything else, instead only giving the same message that you are getting - an erroneous message about a baud rate difference.

For me the fix was to simply to add a reset button by soldering two pins onto the USB connector board (the RST pin and a GND pin). Next:

  • Xbee connected to the computer and powered up
  • Enable API -> OFF
  • Baud rate -> the value you want to be using (mine was 57600)
  • Always update firmware -> ON
  • Select modem type, function set and version etc

When the write button is clicked, after a few seconds the message about resetting various modem types should appear (with XBees listed as the third option). At this point connect and then disconnect the two pins soldered on with a wire to initiate a reset (different to just unplugging the XBee from the computer).

The message should then disappear and for me the flashing process completed successfully.

I hope this helps your situation as well :slight_smile:

Now if only I could get the two XBees to talk to each other…


First of all, thanks again for your responses :slight_smile: I’ve tried to flash another device (znet -> zigbee) and now it workes. What was the problem? I dont know…I just followed the official manual now. However it is not very different to which I did. Maybe the mistake of this failed flash was that I have taken the wrong module. The manual says, that you have to choose ‘XB24-ZB’ if you want to upgarde from a XB24-B. Or maybe there was really a fatal connection error. Anyway the official manual seems to be correct. There is just a little point which I want to add: the manual says that you have to choose ‘Hardware’ als flow control option. Because I just can communicate with ‘no flow control’ , I didn’t change it to Hardware :wink:

best regards