U-boot Build

I am trying to rebuild U-boot without the serial port enabled, but it will not build at all, I followed the readme from the CD, but it appears to not have a \boards\UNC90 folder. Am I missing something?

I don’t know what version you have, but in my version of u-boot, I see a /board/unc90 directory. Did you do a ‘make unc90_config’ first, then a normal ‘make’?

Version 1.1.3
I first tried to use the build script as per the readme file, but that diddn;t work, so I resorted to a make unc90_config and then a make, there is still no /board/unc90

Could you post the files in that folder?

When you do make unc90_config and then a make, what happens? Does it fail? If so, what is your failure? The board/unc90 directory should just be in the U-Boot source dir, not literally at /board/unc90.

> cd U-Boot
U-Boot > cd board
U-Boot/board > cd unc90
U-Boot/board/unc90 > ls
config.mk flash.c lxt972a_unc90.c Makefile u-boot.lds unc90.c

Are you using the u-boot provided with LxNETES? The one from the u-boot project site probably won’t have digi’s patches added to it.

Basically I get a dependency error when I try to run make.
I am using the U-boot provided with LxNetes, from the CD. I have narrowed it down to a corrupt CD, I can’t actually read the unc90 directory on the CD, when I copied it across it has just ignored it, do you know where I can get a new copy of the U-Boot directory?

I’d suggest contacting digi to get a new CD.

Cheers, Sent a support request last night for one.

Thanks for the help.