Ubuntu Heron 8.04 + Digi Linux 4

Has anybody successfully installed Digi Linux 4 onto a Ubuntu Heron 8.04 build?

The install went fine and I could connect to my ConnectCore 9P 9360 and write, compile, run, debug my own programs. I couldn’t however get the kernel configuration to run.

I can’t see that there would be a problem with the above so I’m sure it is just a bit of button pushing from my end.

I’m trying to install Digi onto a PC with Ubuntu but I can’t boot the target. I have connected my PC and the target with serial port, but when I reset the target, it doesn’t boot.

Could anybody help me or tell me any advice.


You have to change from Digi El Configuration the manner of use Graphics Windows System.
Usually DigiEL is setting to autodetect, change to xconfig (if you have installed Qt) or gconfig (if you have installed GTK)

Best regards

I have the very same problem with Ubuntu Karmic Koala.
I am with Gnome of course and the auto-detect purposely set DEL preferences to gconfig.
Anyway I run into the following error when starting ‘configure project’:

make -k gconfig 
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
make: *** [gconfig] Error 2

I checked that every possible GTK library is installed from gtk±2.18.3 on my host.
I don’t see clearly what glib and libglade refer to when running the synaptic package manager from Ubuntu.

Switching to xconfig brings errors too.

Best regards.

I got a reply from a friend who had the same problem with Ubuntu Karmic Koala:

Run “synaptic package manager” and make sure

  • libglade2-dev
  • libgtk2.0-dev
  • libglib2.0-dev
    are installed. Some of them are not by default, hence the problem.