Unable to discover XBee Light Sensor with XStick

I have an XStick (XBee model) with XCTU, as well as three peripherals: two XBee Smart Plugs and a XBee Light Sensor.

Within XCTU, I am able to initialize the XStick and discover the two Smart Plugs, however I cannot discover the light sensor. I tried the “four button press” technique to get it to disassociate from any networks it was on, I’ve tried resetting it, etc. No matter what I do, I cannot discover it.

The association light always stays solid green, and never flashes which I believe means it’s not associated. When I do the 4 button click, it does not begin to flash like it is scanning or anything, it stays solid.

I was afraid that it accidentally had security set on it, so I decided to put together an XBee Adapter (http://ladyada.net/make/xbee/index.html) and read the configuration in XCTU.

The Light Sensor is set to API mode, and I attempted to set default values and re-write the configuration. No matter what I try, I can’t seem to discover it.

I’ve attached my configuration for both the coordinator (XStick) and light sensor. Does anyone see anything wrong?

One quick idea - check your SC setting. You are using 0xFFFF, but I don’t think any Digi Xbee supports FFFF.

New Xbee support either 0x3FFF or 0x7FFF, while old Digi Xbee only support 0x1FFE. What this means is that the coordinator MIGHT select a frequency which the LTH sensor XBee cannot access, thus it will never connect.

In general, I set this to 0x1FFE is there is any chance that an Xbee older than a few months might need to connect.