Unable to open serial port:NONE

Digi ESP keeps saying this when I start to debug.
It keeps automatically opening the Serial Console window. How can I disable this behavior? I would like to see the normal Console window when I’m debugging.

There is aworkaround. It sets the serial port to a value that is not a valid com port (NONE). The serial view will open but the connect will fail. However, the debug session will go on it’s way.

  1. You need to turn off the ‘.*’ filter in the C/C++ Projects view. Select the project, and then select the drop down menu (v) and select Filters…

Then uncheck the ‘.*’ to include the settings in the view and select OK.

  1. Now you will see the .settings directory in your C/C++ Projects view. Expand the directory and open the com.digi.netos.prefs file.

  2. Edit the file and change the line:



and then save the file.

  1. When the debugger is launched, it will open the view and try to connect to NONE but it will fail quickly and continue on.

It is already set to NONE.
What I would like is this: the serial console window shouldn’t open. I just want to see the normal console window when launching a debug session.