Unable to perform lookup (ATLA) after network registration - DNS servers both


I feel like I must be making a rookie mistake. Once my cell modem is registered (ATAI is 0, I’ve got an IP address, etc.) and I try to convert a domain name (e.g. www.google.com) to an IP address via the ATLA command, I get the response “ERROR” - not sure why?

Then I thought “Oh maybe I need to configure the DNS servers” but it looks like ATN1 & ATN2 are read-only (maybe set by network during registration? Unable to set / override?). – they are both

Any thoughts on troubleshooting this?

Thank you!

Following up to my own question here:

My customer just informed me, “We don’t have DNS set up on the test APN we supplied to you, just use fixed IP addresses of our servers for now”.

So in other words, it’s a network (really I guess an APN) configuration issue, nothing that can be set / configured / changed in the modem.

Sorry for any wasted time.

That is correct. The APN would need to support DNS for the LN function to work.

OK good to know – thanks for following up.

If you’re encountering an “ERROR” response when using the ATLA command on your XBee Cellular module to perform a DNS lookup, here are some troubleshooting steps you can try:

  1. Verify network registration: Make sure your cell modem is properly registered and connected to the network (ATAI should return 0).
  2. Check signal strength: Ensure that your XBee Cellular module has a strong signal for a stable connection.

By following these steps, you can troubleshoot the issue with the ATLA command.

Hi thank you for taking the time to reply!

As it happens, the network registration was fine and the signal strength was at its maximum – the issue was that my client hadn’t enabled DNS within their APN. They’d always fed me hard-coded IP addresses within their 10.XXX private network, but when I tried reach outside the network it didn’t work.

They told me a few days ago when I asked “Are you sure address lookup should work? The DNS servers are both and those are provided by the network”, they replied: “Oh we don’t have DNS configured for the APN, that’s why it’s not working, sorry”.