S6B Alias / CNAME resolution issue

I’m experiencing a limitation with a XBee S6B in regards with DNS resolution with the ATLA command.

When the queried dns is a Host (A), the resolution works correctly, but if the same address is tranformed into a CNAME (Alias), the S6B is unable to get the resolve ipv4 adress.

I’ve tried using different DNS server, including the default OpenDNS address, google’s DNS and my corporate windows DNS. When I debug the DNS server, it shows the query coming from the XBee module, resolved by the DNS and returned to the module. But the module still output “ERROR” for resolution.

Am I right to say that XBee S6B can work only with HOST (A) addresses ?

Yes it can. This sounds like you may be using an older version of the code that was having issues. Try making sure you are using the most current version.

Most of the devices in which I have the issues are on 2021 firmware. But I did take a few of them and upgraded the firmware to the latest available from Digi, 2024 and had the exact same result.

Then I would suggest submitting a case to Digi Tech Support indicating exactly what it is you are seeing and exact steps on how to reproduced the issue.