Updating the problem to flash memory DIGI ME9210


Excuse me for my english.

I have error when I updating flash memory to 9210.

I tested the image linux tftp. This is good.

I tried to update as tftp but I have an error message immediately.

I rebooted to the flash, then perform the update but I have a error message about 69%.

Error is : "Error while transferring images.

In “Flash Update”
I added:
----mtd2 / Kernel —> ulmage-cme9210js
----mtd3/RootFS-JFFS2 —> rootfs-cme9210js-64.jffs2

I checked for the tests:
----Transfer to RAM
----Verify copying
----Compute checksum

Thank you for your help


I assume you are trying to update the flash with update_flash within a running system.
Please make sure that there is enough space left for the complete image file. You can check this with the command df -h.
The command free shows you the amount of free RAM in KBytes.

F. Kerkhoff


Thank you for your reply.

With DIGI Connect ME9210
/ # df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 1.0M 1.0M 0 100% /
tmpfsdev 64.0K 4.0K 60.0K 6% /dev
tmpfs 1.0M 28.0K 996.0K 3% /tmp

With DIGI Connect ME9210 jtag
/ # df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 1.5M 1.3M 176.0K 89% /
tmpfsdev 64.0K 4.0K 60.0K 6% /dev
tmpfs 1.0M 28.0K 996.0K 3% /tmp
/dev/mtdblock4 960.0K 272.0K 688.0K 28% /jffs2

My images:
rootfs-cme9210js-64.jffs2 2.9Mib
rootfs-cme9210js.squashfs 2.1Mib
uImage-cme9210js 1.0Mib

I use only rootfs-cme9210js-64.jffs2 for mtd3 / Rootfs
and rootfs-cme9210js-64.jffs2 for mtd2 / Kernel

I do not know what is a image: rootfs-cme9210js.squashfs


it looks like there is not enough space in the rootfs partition (mtd3). The partition must be at least as large as the image file (rootfs-cme9210js.jffs2)
You can adjust the partition table with the flpart command in the U-Boot bootloader.

SQUASHFS is another compressed filesystem for flash memory. You can either use this or JFFS2 as file system for your root partition.

F. Kerkhoff

Thank you for your help, I tried today