usb Xbee3 Zigbee 3.0 device discovering error

Hi all,

I’m an absolute beginner (with Xbee).

I’m trying to discover devices with the USB Xbee3 dongle (XB3-24 family), running firmware 100B (on all devices). I have two Xbees 3 one as network role Network form (coordinator), one as join network and the USB Dongle mention above as join network.

Both Xbees are connected and communicating. All good with those.

The problem is, when I want to use the USB donge to discover devices, so I could access the network without USB cables… When I try to discover devices on the dongle through (XCTU), immediately I get the error: device discovering -> status error. I can write configurations to the dongle without any problems. Except discovery devices, it’s functioning correct.

So firmware is 100B, WIN10, XTCU v6.5.5.

I tried to downgrade firmware, without success.

Any help would be appreciated.

You can only have one coordinator. All other radios must be configured as a router or end device. You also need to have the radio connected to the PC in API mode for the Remote network discovery to work.

Thanks for the answer.

Maybe I didn’t expaine well enough.

One Xbee is router, one router and the usb dongle as end device. They all in API mode.

The usb dongle throws an status error, when I click the discover network. When I start discover network on both other xbees they see each other, but not the dongle.

On the Network working mode view (in XCTU) when I Start the scan of the dongle I get a message: “Error discovering neighbours 0013A20041A1BD1C. Cannot find the local device 0013A20041A1BD1C address. Remove it from the Radio Modules list on the left and add it again.”

The 13A20041A1BD1C is the USB dongle’s SH & SL.

Bdw I did try to remove it a couple of times from the Radio Modules list and add it again, without any changes.

For Zigbee Mesh to work, one of your modules MUST be a Coordinator.

Sleeping end devices will only respond to a discovery when connected to the network and on.

Like descriped abowe, one modul is coordinator, one is router, and the USB dongle is set as router. Coordinator and first router are functioning correctly, the problem is the USB dongle, which can’t even discover devices, because it throws an status error… All in API mode.

What is the part number of this USB dongle?

Are you able to read and set its parameters in XCTU?

Do you have the XBee in API mode?

PN: 50001993-01 Rev B

Yes all in API mode.

Yes, no problems changing any parameters. Tried to change the firmware, same results on ZigBee 3.

Bdw just updated the firmware to DigiMesh, all works with that, but not ZigBee.

Ok getting closer. It works with ZigBee 3.0 firmware 1009, but not with 100A, nor 100B. At least it doesn’t throw an error when discovering network, but still can’t see any other devices. SC set for all chanenls…

Sorted out!!

The problem was the Thunderbolt dongle. I plugged the USB dongle straight to the USB3 laptop, and now everything is working!!!

Thanks for the suggestions anyway.