Very low RSSI

I’ve been trying to set up a network with two X-Bee modules.
I’ve been working in the past with Zigbee, but always in transparent mode, so now I have a micro connected to a module configured as Router sending a data packet and another module configured as Coordinator connected to the PC where I see the message, all controlled in API mode.
The modules are two Xbee 1mW with wire antenna, both with PL=4 and PM=1.
The problem is that I cannot take them more far than a couple of meters…
The RSSI is -65dB at 50cm of distance, falling rapidly to -80dB, where the communication stops.
I’ve tried to turn off my WiFi, just in case, but there is no change in the link quality.
Power supply is fine, 3.3V stable, the test is made in the same room so almost in line of sight, the configuration looks fine to me… so I basically have no clue on what is wrong.
Does someone have any idea? [:-/]


Hi all, I finally found a solution.
It looks like it was a firmware problem.
I’ve been trying many times to reload the firmware, but always the same version, until I came to this post:,9864 .
So, I was running the 21A7 / 23A7 on the XB24-ZB, getting -65dB of RSSI at 50cm of distance. I loaded the 2164 / 2364 and magically, without touching anything, I got -25dB. Now I can transmit at three rooms of distance, which is a HUGE improvement.
So, well, if someone gets this range problem with S2 devices running in API mode, DON’T use 21A7 and 23A7 firmware. [:">]