web page freezing problem on Connect ME module


I use Connect ME and I have used digi starter kit. We used serial port and when digi received data form serial port, web page was freeze. We used modbus rtu for serial communication. Max packet size was 40 bytes. If we had stopped client MCU, Digi module would have sent serial data and it’s web page wasn’t freeze. But if we had started client MCU, Digi module would have sent serial data and received answer from client MCU. And Digi web page was freezing.
We increased thread stack sizes (new HSF thread size is 32768 byte) and our problem seemed as solved.

Now I add some java functions whcih I take from Frontpage 2003 program. Our problem again occur. I think, last time, we didn’t solve the real problem.

We used digi weateher station as a sample. NETOS ver is 7.1



Please give me a more accurate definition of the following phrase: “web page was freezing”.

Can you still "ping" the board when this happens?
    Has the entire device stopped functioning or just the web sever conponent?

Can you get this to happen in a debug environment?
    If yes, can you set break points in the error handlers in init.s and are you hitting one of the error handlers? If so which one?

One possibility comes to mind but given the scarcity of information, this is purely a long shot. After running web pages through the PBuilder utility (Assuming you are using the advanced web server (AWS) as opposed to the basic web sever - BWS) the "get" functions have a char * that is used for returning the object to be returned by that function. That char * is purely a place holder. If you use it as is, you will probably cause a data abort. You need to have either malloced space or a global variable that is being returned.

You might also look at the white paper on the Digi web site entitled using the advanced web server.

Also have yo applied all patches on the Digi web site associated with NET+OS V7.1?


When web page freezes, Digi Connect module doesn’t give any response. For any netospog commands such as “netosprog /discover”. Especially, it occurs when I open secure page than open insecure page. (first I open home.htm than open web_files.htm and enter user name and password than I open home.htm and it never comes)We change names of web pages.

I send my web page codes and *_v.c files.
Would you check it?

When I wrote java script codes in two tags, Digi web server freeze on debug mode. But now it isn’t freeze. (I send the example). I copy thread state when it freezed on debug mode.
State was:
Thread [15 HSV] (Suspended: Signal ‘SIGTRAP’ received. Description: Trace/breakpoint trap.)
1 waitMills() at .\init\arm7
await.c:134 0x08013944

Now, I check software updates of Digi.

Message was edited by: ficom

I had this problem when I switched from NET+OS 7.1 to NET+OS 7.4.2, and solved it by rebuilding my html pages from the sample generated ones a piece at a time.