WieM: WPA_PSK with AES is not working....

Dear Friends,
My DIGI board WieM works fine for WEP and WPA-PSK with TKIP securities. But when I set WPA-PSK with AES (security = WLN_ENCR_CCMP) then API wln_params() is throws an error.Please help me to resolve this. Other than encryption key (TKIP/AES) is there any changes between TKIP and AES ?
THanks in advance

Message was edited by: devid

You mean the call to wln_set_params, correct? What’s the error code returned?

hi devid, i noticed you got the connect wi-em working for wpa-psk with tkip security. I’m trying to get wpa-psk with tkip security working on a connect wi-me but have had no success. Could you lend me some pointers on how you setup the wireless parameters? I’m assuming there won’t be much difference between the wi-em and wi-me.

This is a summary of my current configuration:
encrypt = WLN_ENCR_TKIP
wpa_psk = <32 characters>

The access point has also been configured for these settings. Please let me know if there are other fields I need to set explicitly?

-1 …i am working with older version of Netos… not with latest version

The error is returned because one of your settings is invalid in the structure you passed to the function. Try putting a breakpoint on wln_set_params and step through the code until you see on which member the error is occuring.

You are corret. But there is no issue till wln_set_params () function. But once i execute this it returns -1. DO u you have any idea of parameter differs from WEP and WPA-PSk with AES.

Sure, you need to set the WPA options such as the wpa_psk, authen, encrypt, etc. However, you do have to fill out the whole structure, not just the parts you want to change. If you’re not already, try getting the current structure first using wln_get_params, modify what you want to change the encryption, authentication, keys, etc, to, and then call wln_set_params.

If you’re still having problems you need to debug as mentioned above.