wlan driver fails to load

I’ve compiled an image and am booting it via network (https://www.digi.com/resources/documentation/digidocs/90001548/#task/eclipse_ide/new/boot_your_images_from_network.htm%3FTocPath%3DDigi%2520Embedded%2520Yocto|System%2520development|Program%2520devices|Boot%2520options|_____1) but the wlan is still not showing. I noticed that upon boot, it actually says “wlan: driver load failure.” I then tried “sudo modprobe wlan” and I received the following message:

modprobe: can’t load module wlan (extra/wlan.ko): No such device

What am I missing here?

I built the image with the following in my config file:


EXTRA_IMAGE_FEATURES += “eclipse-debug”
EXTRA_IMAGE_FEATURES += “dey-network”
EXTRA_IMAGE_FEATURES += “dey-wireless”

are you using cc6ul SBC starter board? Does it work with stock images?

I’m using the cc6ul SBC pro board. WLAN drivers load fine with the stock image, yet when I compile a custom image they don’t load.

Using these instructions:


along with booting from network:


your original post pointed to a document related to a different board (cc6ul starter). Are you sure you are building images fro SBC Pro?
source /usr/local/dey-2.2/mkproject.sh -p ccimx6ulsbc
Do you see any errors in the bootlog?
We have done this many times and never seen this problem before.
Please not that correct way to add features from your original post is:
EXTRA_IMAGE_FEATURES = " eclipse-debug tools-debug debug-tweaks"
note the space after first "
Also if you update to DEY 2.4 r1 which is the al test version right now, you would not need to do this.

Yes, I’m building for the pro board. I may have accidentally noted the starter pages (as I’m also using a start development board separately), but i am sourcing the script with ‘ccimx6ulsbc’

I’m assuming that if I built the image for the starter board, I wouldn’t even see anything regarding wlan (though this is just a broad assumption).

I have a separate issue with DEY 2.4 in that when I try and build with DEY-2.4 the bitbake build stalls out on

glibc-2.26-r0 do_fetch

it appears that it never completes. I’ve had it going overnight and never completed. I’ve cleaned my DEY-2.4 work environment up and tried to create a new DEY-2.4 environment with the same results. Its like its not resolving to the repository correctly. Its why i’m working with 2.2 because I’ve not had the time to fix this issue.

Perhaps it could very well be the lack of spaces in the local.conf macros I have that are causing an incorrect build with DEY-2.2. I’ll fix that and see if anything changes, I never noticed that before.