XBee 3 Global - High Data Consumption


Captain Destructo here, got another odd ball with one of my XBee3 Global Low-Power. It’s still sort of connected to another thread I started regarding issues with connect attempts to our cloud storage provider’s MQTT server. I feel a little dumb for not noticing this sooner, but the trouble devices are burning data. A lot of data. My normal deployed devices burn around 200-300kB per day and these troubled devices are burning about 4MB per day or more. I have no idea what the devices are RX/TX that is causing it.

I started digging into API logs, Digi Remote Manager, etc trying to track down exactly what data was sent/received. I can’t find it. I ran a few tests with this particular XBee 3 Global (low-power) and the device burns quite a bit of data with nothing running. I formatted the memory so there is no MicroPython code running and I disabled DRM on the device. It still burned 21kB of data in 5 minutes of up-time! It was just a simple connect and disconnect. It did not connect to DRM (that I can tell) and there was no MicroPython code that would have tried to send/receive any data.

I figured that there is some overhead data for the network itself (some handshaking and security stuff) so I set up a known good/normal device and repeated my connect/disconnect test to get some baseline. No code running and did not connect to Remote Manger. It consumed only 2kB of data according to my provider’s session history. This overhead consumption would be consistent with what I see with my other “good” devices. These devices that aren’t burning data – I have no issue with them at all. They are extremely consistent and bulletproof.

Just to further describe whats going on, I left this troubled device on for 24hrs with no MicroPython code running. It was just connecting to DRM every 12 hrs (twice a day). It consumed 2.3MB of data! Sending/receiving what? I do not know. Was hoping someone would have some ideas for me.

What have I tried? I tried a new SIM, reformatted the memory, re-installed the latest firmware, tried to re-installed the modem firmware (that failed two times and was never successful. Error with something close to “could not find insertmodemfirmwarenumber.exe file).

A few ideas:

  • Socket(s) is somehow still open on the modem? Formatting flash/hard reset does not clear it?
  • Remote Manager(RM) is interacting with it but it’s not showing up anywhere in RM?
  • Device has been hijacked? (Highly unlikely, new SIM would resolve?)
  • I managed to scramble it with my god like skill of destruction. (wouldn’t be surprising).

Any direction or ideas on this would be helpful. For now, I have just put this device aside. However, I do have two deployed that are having some connection issues and their behavior is similar to this device. Luckily they are not burning as much data as this particular device, but consumption is still elevated so I suspect the issue is related.

Thank you for any ideas,


I would suggest submitting a Support case to Digi Support.

I would suggest using the XBee Recovery tool to down grade the firmware and then upload the firmware.

I would also suggest having the Carrier put a trace on the Line of service to see what it is doing. Then do the same to a working line and compare the two.

Will do. If I get to the bottom of it, I will update this thread for reference. Thank you!