XBee not sending data packets in API mode

I have 2 XBees S1 Pro, one is transmitter in API mode, the other one is reciever in transparent mode. I am sending data packets via MCU PIC30F5011. If I try to send the packet from transmitter via uart the packet is not sent. However if i connect the xbee into a computer and try to send the same packet with XCTU or LabView the packet is fine and the Xbee have no problem sending it, so the packet must be correct. I also tried connecting the uart into computer and check the output in Teraterm and the packet looks exactly the same as the one from XCTU.

It is probably either a Voltage issues or a timing issue on your processor. Keep in mind that the XBee is a 3V device and in order to connect it to a 5V PIC, you must use a level shifter between the two.

Thanks for contribution, but I don’t think this is the problem. I measured the whole board with oscilloscope and the voltage levels were alright.

If you connect your PIC to the PC via the port you are using for the XBee, are you able to see the same packet in your terminal screen or XCTU?

Yes, the packet is the same and is also fine with XCTU packet control.

Than the only thing left is the hardware interface between the XBee and the PIC. This means that the issue must be in the level shifters.

Thanks for your replies, but I just solved the problem. It was not the level shifters, but baud rate, I think the PIC is too slow and cant keep up with the 115200 baud rate. Working when you reduce the baud to 57600.