Problem with transmission.

Hello. I encountered 2 problems. First : I need to transmit voltage from end device , that varies from 50mV to 1V. And when I receive it I see in XCTU that voltage was in hex 3FF, but I set voltage from generator 75mV. And read previous topics and turned off pull-up resistor, but nothing happens. I set up dio1 as ADC.
Second : How to transfer the information that was received from the end device on the external microcontroller which is connected to the coordinator?
I connect xbee dout with rx pic16. I initialized uart in pic16. But information don’t come from coordinator.
I’m using xbee s2c.

What voltage level does you Pic run at?

Do you have a level shifter between the XBee and the PIC?
Have you read over the ADC section of the manual? That is page 132 - 138.

There is no level shifter between Xbee and the PIC.
I don’t pull off xbee s2c from xbib-u-ss revB.
Pic is running at 4.5 V.
Can u answer pls, why am I receiving 3ff in hex, while I transmit 50mv?

You need to put a level shifter between the 3V XBee and 5V Pic otherwise you will damage the XBee.

You are not interfacing with the radios properly. This is why you are getting voltage out of range values.

For what I need level shifter? Xbee and pic have different sources.
Can you say, how I need to interface properly?

You have to have a level shifter as your Data lines from the Pic are still running at 5V. The XBee is a 3V device. You can’t connect its 3V Data line or any other line to a 5V device direct without damaging the radio.

So after I use level shifter I will receive proper information from xbee?
What kind of level shifter I need to use

The information provided at has a 5V radio connecting to a 3V processor. Just simply swap which device is where and you will have what you need.

Will this resolve the issue? That is unknown as you may have damaged the XBee module.

Ok, thank you very very very much.
Ou, 1 more question. In some topics, people says, that if you disable pull up resistor you will receive proper information.
I disabled it and nothing happens. For what I need to enable/disable pull up resistor ?

I run both pic and xbee on 3v. But problem with 3ff still don’t solved. What I need to do?

Remember when I said that you may have damaged it, well you may have.

As for your other question, you are really going to need to look in the actual product manual for the specific XBee module / protocol you are using to find out what AT command is used to enabling the Pull up resistors. I can’t tell you with information you have provided as you have not provide which XBee module you have or what firmware version you are working with.