XBee Pro S1 sender with S2C receiver (802.15.04) problem

We are useing Xbee modules (mostly XBP24 S1 types) for about ten years without much problems. Now we would like to change to the new S2C modules (XB24CAPIT-001 firware: 2001). I made some test and it seems that the new modules doesn’t work properly for some reason.
The use scenario: an XBee pro S1 module is the coordinator and it send data at 100ms intervals. If the receiver (end device) is an old XBee S1 module then everything goes well - it associates to the coordinator and then receives the data without losses. If I change it to the new S2C module then it sometimes associates to the coordinator, sometimes not. If it associates then it receives the data with many lost packages, so the connection is very unreliable for some reason. (the networking parameters are the same in both modules)
I tried the sending (S1) side with an other type of PCB, and it seems that this case the new S2C module works well. So it seems that the problem is somewhere in the first PCB, but I don’t know what to see as we use this type of PCB with the S1 modules for some time withot problems. and in my test an old S1 module receives the data well while the new S2C not in the same situation. I tried to change (enlarge) the capacitor on Pin 1 (power) of the module, but it haven’t helped.
Does anybody had a similar problem?

thanks your replies in advance!

What parameter are you using on both the Coordinator and end device?

Thanks for your answer, but I think that in the meantime , I’ve found the cause of the error. It seems that ripple on the power input caused it. It was about 70mV peak to peak - which was lower than the 100mV value in the datasheet (to tell the truth the switching frequency (~50kHz is much lower than the adviced value), but it caused the problem. With a very big capacitor (100uF) on the power pin it lowered to about 50mV and it seems to be working.
The interesting thing for me that why the S1 modules can receive the same signal much better than the S2C from the same (noisy) S1 sender?

Different processor, chip set and a few other things used.

check the s2c module once which firmware version havw you loaded. why because s2c will support 3 firmware version now

  1. 802.15.4 same as s1
  2. digimesh 2.4
  3. zigbee

for your case you need to load 802.15.4 version.

Thanks for your answer!
The firmware is 802.15.4.
As I wrote above the cause of problem was the noisy power supply on the S1 side. (So S1 (with noisy power) -> S1 works without problem, but S1 (with noisy power) -> S2C doesn’t work)