Xbee S1 Coord and Endpoint API getting no response after a period of time

I have one XBee setup as a coord and another as an endpoint. Coord is setup with CE=1, both on the same ID and CH and AP=2 . The coord is connected via shield to an Arduino Mega on serial1 using the XBee API library.
On power up communication works perfectly, I can send data from the coord to endpoint and receive. The problem occurs approximately after one minute with no data being sent either way, sending a command to the endpoint results in a 0x04 no response status from the coord. I’ve tried a few different XBees as endpoint, same result. Different XBees as coord, same result. Reseting the endpoint, still no response. The only way I can reestablish comms is by sending an ND (Network Discovery) command to the coord, to which the endpoint replies and then I can communicate with the endpoint again. But if there is no comms for a minute, comms is lost again. I’ve gone through the XBee manual with a fine tooth comb and I can’t find anything to explain this, any ideas would be appreciated.

Finally figured it out for those of you interested. The XBees had version 10CD loaded. Once I upgraded, the timeout disappeared.