Default sleep timeouts not working as expected

I have XBee Pro SB2s (XBP24BZ7), and am creating a mesh networking using API mode 2.

All configuration is the default except PanID (ID) and ApiMode (AP).

I have a Co-Ordinator plugged into XCtu using an XBee Explorer.
I have an EndPoint attached to an Arduino Nano. When triggered it sends a 0x90 Recieve Packet every 1000ms.

The problem is that every time the EndPoint is triggered, the polled messages will fail to send N times until it starts to send OK.
The devices are connected OK, as I can use the Scan feature in XCtu to discover and read the EndDevices.

N has always been greater than 4 and has been as high as 8.

Once the N failed messages happen, I can stop sending packets for about 6-8 seconds and be able to start sending again without delay. However, going past that causes the N count to happen again.

I’m assuming a problem with Sleep/Timeouts, but these settings have not been changed from their defaults.

I can see the endpoint is sending the packets as expected using serial - it gets a 0xFF error code for the N messages which fail. These messages are never heard of by the Coordinator. I can see when the coordinator starts getting the messages using XCtu Console (or the Green LED on one of my XBee Explorers).

I would expect the delay to have a maximum value of SP * SN (320ms*1), but in reality, I’m getting 4-8 seconds.

If the problem is with sleeping, what changes to the default values do I need to reduce the send/receive delay to <500ms?
I have tried various other sleep modes, but none have solved my issue.

Thanks for any help.