Xbee 2 sleep SM=5 not working

Hi everyone ,
I’m trying to connect my 2 xbee2 module one like coordinator api and other like end device api.
I set the end device to sleep 1 minute and wake up for 500 ms. I want just to send 1 packet to the corrdinator so these are my setting:

End device version 29A7:
SM=5 , SP=7D0(20 sec),SN=3,SO=4,ST=1f4(500msec),IR=3e8(1sec since i want to send just 1 packet).

Coordinator version 21A7: SP=AF0(28sec)

The problem is that the coordinator receive 6 packets and not 1 packet. Why this happens?
Hope in help thanks a lot

Have you tried with SP=1770 (60 sec) and SN=1… were you still able to see the issue ?

Hi killer32 and thanks for answer .
I set SP to 20 sec (7D0) since in the datasheet it says that max value is 28 sec.

I solved the problem by reprogramming the firmware with no AT parameters an then writing these parameters again using XCTU.
The first time, after some times it sent just 1 packet per second, as i expected, suddenly started to send again 6 packets with no reason.
I repeated the procedure again and now it seems to work correctly (1 packet per minute). Hope it keeps this behaviour since i have to set the sleep cycle to more minute than 1 to save battery power.
thanks i’ll keep you updated.

Here we go again! Today trying to extend SN to 30 since i want 10 minutes sleep period (SP=7d0 x SN=30 ) but nothing to do! it still send 6 packets about 1 minut at time. I dont understand what’s happening , i read the whole datasheet. I wonder if i have to change the version of the firmware in both coordinator and end device! an help please on what i’m doing wrong!