Sleep Timers too low for X-CTU to work?

I now have two XB24-ZB modules in the same unresponsive state. I tried to configure cyclic sleep timers on them to the following settings:

SM = 4
SP = AF0
ST = 64


According to the manual, that should give me a sleep period of 28 seconds, and a sleep timer of 100ms. This works for what I am doing in my device. The problem is that I can never talk to the thing again using X-CTU. At best, if I time my click exactly right, I can get X-CTU to identify the modem, but I can’t ever get a full device settings read or do any writes to the sucker.

Is it possible the ST setting is too low and the modem sleeps before X-CTU can talk to it? I have X-CTU set to API mode, so that is not the problem.

I’ve tried pressing the commissioning button on the modem which should allegedly wake the thing for 30 seconds. Instead it wakes it for about 1 second and it sleeps again before I can read anything from it.

They work like happy little champs in my microcontroller application, so the hardware is good. They just won’t ever talk to X-CTU.

I’ve been through the basics on this one (putting X-CTU into API mode, verifying com port settings, etc.) X-CTU reads other modems with the exact same firmware but different sleep timers. Just not these two modems.

Anyone seen this behavior elsewhere?

Could you send a remote command to change the Sleep values.

Yep. I did just that to get these two back to life.

Annoying situation, but not unsurvivable.