no response of XBee ZB since update firmware

Hello. I’m quite new with XBee ZB… so I suppose I made something wrong !
I’d like to have a serial communication between 2 µC. And I’d like to use an alimentation of 2.4V. So I choose 2 XBee ZB.
With the X-CTU software and a XBee Usb Adapter, I configure 1 Xbee as Coordinator and the other as End Device.
The coordinator is ok.
But since I’ve configured the end device, he doesn’t want to communicate with modem.
I make the same with another XBee ZB, and the same happened ! No more communication with X-CTU.
Modem : XBP24-ZB
Version : 2870 ?
Do you know what can I do ? Thanks.

Did you change the baud rate? If so, it helps to set XCTU to the exact speed required.

If the XBee sleeps, then it can be hard to talk to. If you enable the “commissioning button” support, then pressing that button forces the XBee to wake up and remain awake for 30 seconds.

Hello lynnl. Thank you for the answer.
I didn’t change the baud rate. (it’s 9600)

I don’t know if the XBee is sleeping (I can’t read its configuration).
But in the Terminal Tab, I can see the CTS status : it goes green for 1 secondes every 20 secondes. I toggle the DTR line (also in the Terminal), but it has no effect…

Where is that commissioning button ?

Some news :slight_smile:

I 've found the commissioning button (link between pin 20 and ground).
The CTS line become green in the Terminal Tab during 30 secondes.

But no response ! I’ve tried all the possible baud in the PC Settings Tab, always “Unable to communicate with modem”

I have exactly the same problem. Brand new pair of XBee XB. Config’d one as Coordinator, wrote config, no problem. Installed 2nd module in USB adapter, config’d as Router/End Device, wrote config. After that I cannot talk to module.

How does one do a reset?

OK, I got the module talking to X-CTU again. Pheew, I thought it was bricked. Found another thread that suggested something and it worked.

  1. make sure “Enable API” is off (PC Settings page)
  2. select “Always update firmware”
  3. select the Modem type in the pull down (in my case “XBP24-ZB”
  4. select “ZIGBEE COORDINATOR AT” for the Function Set
  5. select most recent firmware (I had 2070)
  6. click “Write”
  7. when error window pops up “unable to communicate”, ground RST pin for 4 seconds then release.

when I did this, X-CTU updated the firmware and now the module is working again.

Are you using an official Digi XBIB USB, or another? Your board (& it’s driver) needs to support enough control signals and long-break.

Unfortunately, working with XCTU and Xbee can be a bit of a black art - you need to get a feel for it. I also find sometimes closing XCTU and restarting helps.

You could try to look at this:

Hello everyone. Thank you for your answers.

I use a XBee Usb Adapter from Parallax (I think the control signals are ok, I mesure DTR, CTS. And there is 4 leds working).

I made your method WBPHELPS… and it works very well.

So, I can again talk to my XBee. YES !!!

I suppose I have to try an other firmware. Maybe the 2864 ? Or the router one ?

Generally, you would only use ‘End-Device’ firmware if you plan on having the device sleep. They are not part of ‘the mesh’, so must have direct line-of-sight to a parent. This also means they cannot help add robustness to the mesh.

If your device is always powered, then use router firmware.

Hi Digi international tech support

I purchase 2 XBEE XBP24-ZB module 2 months ago
I was able to get connection between them by setting 1 as coordinator and 1 as router in AT mode firmware 2064 and 2264 respectively

now it is not working

so i tried to reflash the xbee module
while reflashing the the X-CTU got hanged
after restarting the X-CTU : while test and query i get the following error as unable to communicate with modem
check with all the baud rates and also by enabling API mode but no success . So please help me as

To make the end device to associate with the Coordinator, you may need to try with different and unique PAN ID. Set SC to maximum to scan all possible and applicable channels. If you get “unable to communicate with the modem”, the first step is to check the COM port and baud rate settings under PC settings. Then reflashing the firmware on the module with latest firmware also helps. Better communication is guaranteed with digi interface boards.