XB24-ZB has turned into a brick

I have a brand new XB24-ZB and it has stopped responding to X-CTU after I tried programming it.
I know it is not my programmer because I can use another XB24 in it and the comms work fine.
The ON/SLEEP signal is strobing on/off at about 1 second on, 5 seconds off and I think this is part of the problem. If I send a +++ when it is not in SLEEP mode then the device stays ON for about 25 seconds or will stay on for as long as there is data being sent to the device.
The trouble is +++ does not put it in command mode.
I have tried a couple of different baud rates (I only played with 19.2 and 9.6kbps) to no avail.
So I think I have two problems. One is it is going to sleep mode and the other is I have put it in a mode where itis not talking to X-CTU.
All help appreciate.


Try these tips:


I found the problem. I am using an Arduino SD Shield to program the device and if you do not have the modem control signals you cannot recover the device.
Through some creative programming and wiring I was able to simulate the modem control signals using the arduino and I recovered it.
If anyone ever has the same problem drop me a line and I will send you the code.
Chapter 11 in the reference manual that describes how the boot loader works is key. If you can get that far with an SD shield then you will be able to get it back.
The support team were brilliant in helping me work through this.

The manuals say to never update the firmware without the modem control lines