XBee series 2 - after ATDN command part of first message is lost


I’m using XBee series 2, hardware version: XB24-BPIT-004 revB, software version: XB24-B, ZNET 2.5 COORDINATOR AT 1047; XB24-B, ZNET 2.5 ROUTER/END DEVICE AT 1247.

I encountered the following problem: after sending ATDN command to XBee (it returns OK and according to documentation should immediately switch into communication mode) I try to send a message to the node but part of the first message or the whole first message is always lost. The second message and following messages are sent without problems. I tried using delays after ATDN command but it didn’t help, the information is lost. Also tried changing the baud rate, didn’t help either.

I’m not using sleep mode at router/end devices for sure (SM=0).

Could you kindly help to figure out the solution to this problem?


You are reading the Manual for the Current XBee ZB firmware versions (2xA7) but are using the out dated and no longer supported Znet 2.5 Code. I would recommend upgrading the firmware to the current code that matches the manual.

Which firmware do you propose to use? The XCTU application doesn’t find any updates.

Go to http://www.digi.com/support/productdetail?pid=3261 and follow the znet 2.5 to ZB migration document. You need to move from the XB24-B modem types to the XB24-ZB modem types.

Ok, I see. Already tried to use XB24-ZB firmware before (the problem described above didn’t occur often) but there were some other problems, like after sending several commands the module freezes and doesn’t respond. Thanks for pointing out about using the older version!

Sounds like you have a corrupt API frame. Try using API mode 2 (Escaped characters) instead. That will help with it. Also make sure you use hardware flow control.