Xbee UNO connection problems

The problem I have is communication between XBee (on the USB explorer connected to my PC) and the XBee (on the XBee Wireless Shield mounted on the UNO).
If anyone can help me with that step I would really appreciate it.
The XBees (versions) and parts I ordered are the same as in this Instructable, so I’m sure it’s not a hardware problem because it works there. When i was assembling the XBee shield all i soldered was the shield stacking headers, and my UNO is straight out of the box (no jumpers or extras)

Here is my current XBee setup, first for the coordinator(PC) and second for XBee (UNO), both have the latest firmware. and identical Baud rates on the XBees and serial port COM7

Here is a video showing that I think that the XBees are paired correctly because when I type out commands in the X-CTU terminal the red LED (DOUT) on XBee shield blinks faintly, so there must be some signals getting through.
But when I try to upload a simple ‘Blink’ sketch to the UNO I get this error

I tried it with Shield set to either “DLINE” or “UART” & power cycling between takes, still same error

I’m sure my arduino program is set correctly, when i connect through USB everything works as expected:

I’m really at my wits-end, can you please take a look and tell me if there are any differences from your setup or any steps I might have missed? (let me know if the links are broken,)

Thanks in advance guys , any help would be appreciated. :smiley: