XBee ZigBee ZDO command no answer

We are trying to fetch information about the children in the ZigBee network.
In the following document we found Example 1 that states “Format
the command to also discover the 16-bit addresses of its children (if any).”

We are following the example and our resulting frame looks like this:
7E 00 1F 11 01 00 00 00 00 00 00 FF FF FF FE 00 00 00 00 00 00 00 00 01 41 4E EB D8 00 13 A2 00 01 00 E9

The destination router has the address: 0013A20044414EEBD8

We send the frame but there’s no response. We tried setting the frame ID to 01, then we got Successful Transmission Status.

When we tried example 4 we got a response as expected.

How come there’s no response to our frame we got following example 1?

*Edit: Corrected the frame, the checksum was incorrect. But we still don’t get any response.

That is an invalid frame. The checksum should be an A7 instead of an A6.

You are correct.
We corrected the frame and the checksum is now A7.
7E 00 1F 11 00 00 00 00 00 00 00 FF FF FF FE 00 00 00 00 00 00 00 00 44 41 4E EB D8 00 13 A2 00 01 00 A7

We still get no response when sending that frame.

Do you have any Sleeping End device children on the network?

Yes. The network contains both routers and sleepy end devices.
By using XCTU we can see that there’s a end device connected to the router we are sending the frame to.
If we explicitly set the destination address to the router we get a response. But the response does not contain any information regarding the children.

What is the frame you re getting back?

Here is the response we get back:
Start delimiter: 7E
Length: 00 1E (30)
Frame type: 91 (Explicit RX Indicator)
64-bit source address: 00 13 A2 00 41 4E EC 0F
16-bit source address: 10 79
Source endpoint: 00
Destination endpoint: 00
Cluster ID: 80 00
Profile ID: 00 00
Receive options: 01
RF data: 01 81 41 4E EC 0F 00 A2 13 00 79 10
Checksum: DB

This is the reply we get when the 64-bit destination address has been set. If we set the address to 00000000 0000FFFF, as stated in example 1 in the PDF, there’s no answer.
If information about the children would have been in this answer, we would be really happy.

That is a command that really needs to be sent to a specific node and not all nodes.

Yes. You are right.
The frame posted in my last comment is addressed to a specific node. The main issue is that the response contains no information about the children.

Which XBee module and firmware version are you working with? That is, what is the part number of both radios involved and the firmware version used?