Yes, Digi modules. Old uboot image looks like running a bit; new not.

Thank you so much for answer ( i am a bit lost …)

The board i use to program is : Digi CCWi-i.MX28 number 5001837-01 (ref on back 30013792-03 Rev A)

I made different tests with differents CCWMX28, for instance

  • 50001838-24-revB
  • or 50001838-05-revC
  • and other

I first re-programm uBoot using “sb_loader” and the u-boot provided on Digi DVD.

  • With the file “” U-Boot 2009.08 - DUB- - (Jun 06 2012 - 10:16:33) - GCC 4.4.6
    Just after the USB transfer, i leave the boot up to linux and i can access normally the eth0 & 1
    After the reboot, not. (like if it has not been stored)

  • With U-Boot 2009.08 - DUB- - (Feb 19 2013 - 11:37:37) - GCC 4.4.6 or ConnectCard Wi-i.MX28
    No Eth; neither before or after reboot.

And, with all the uBoot i tried to make : nothing with eth (or WiFi)

I tried to re-configure a fully new installed PC with only Digi DVD Kubuntu from scratch; with old version, new versions : nothing

But, i have a tens of old card(RevA) fully running. I did the job some monthes (or years …) ago with no problem.

So, your help is really wellcomed



Make sure you are programing it into flash, use the update command. Take a look at uboot manual.

Section 10.3 shows how to perform an update

It looks like you have a ccwimx28 V3 module, but you are building your own u-boot using DEL that is not up to date and does not fully support V3 variant. What version of DEL are you using? Did you install all the patches via package manager? what is Part number and serial number of the module you are using? Do you need to customize a u-boot?

You should probably open a support case for this if the issue is not resolved by installing the latest patches to DEL and then creating a new U-boot project.