Acceleport Xem on Ubuntu 8.04


I want to share my experience with ubuntu 8.04 server and the Acceleport Xem PCI card.

I builded a deb package from the rpm available at this URL :

with commands :
rpmbuild --rebuild dgap-1.3-14.src.rpm
alien -d --scripts /usr/src/rpm/RPMS/i386/dgap-1.3-14.i386.rpm
dpkg -i dgap_1.3-15_i386.deb

I ran the application mpi, but the system said my card is not configure.
When I tried with the application /usr/bin/dgap_config. (mpi call this app to configure the system)
I got an error at line 2643 with this message : unexpected ‘{’ expecting ‘do’ ?!?!?!?

The problem is the shell interpreter, by default on ubuntu it’s not bash but dash.
ls -l /bin/sh –> dash . sh is a symbolic link to dash . I think dash is a minimal shell.
I changed it for bash
sudo rm /bin/sh
sudo ln -s /bin/bash /bin/sh

And now every things is ok :).

I hope this can help your.


p.s: special thanks for the digi support team, I recieved quick answer.

Thank you so much for posting this. I had trouble all day until I saw that I had to do an rpmbuild before running alien. I kept trying to run alien against the source rpm. One note, dgap-1.3-14 doesn’t seem to be there anymore. It’s -15 now.

Thanks for this information.

Using this same procedure, I was able to install the package on Ubuntu 9.04 “Jaunty Jackelope” with the slight exception that the link above for the source RPM is now one version higher. (As posted above.) As a result, I have a .deb package which is a -16.

One question: The machine that I’m installing this on for now is only a temporary server, and it’s another server which will be put in place permanently. Can I just move the .deb package over to it, now that I’ve rebuilt it, or will I need to go through the whole process over again?

Sure, you can use the .deb image so long as the target system is identical (i.e.: same kernel, architecture, etc…).

Well, here’s to there being a difference between getting something installed, and getting it working.

I’ve got the package installed, however it does not seem to be able to find the card. I’ve got an Xem PCI card, with a PORTS/16EM module attached. I’d think that this should be fairly straightforward. It allows me to configure the card, but the tty devices don’t get created. If I go back into mpi, it tells me 0 boards detected.

Check to make sure the adapter is seen in the system:

sudo lspci

If so, make sure the in-kernel epca driver is not taking over the adapter:

sudo lsmod | grep epca

If so, remove the epca module place the module in another location where it will not load and reboot:

sudo rmmod epca
sudo mv /lib/modules/uname -r/kernel/drivers/char/epca.* /tmp

Thanks for the advise.

sudo lsmod |grep epca

returns nothing, so that doesn’t seem to be the case.

sudo lspci -vv returns:

04:03.0 Communication controller: Digi International AccelePort Xem (rev 01)
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- SERR-

Yes, it appears epca has the adapter. Since it is not showing as a module, it is likely built statically in the kernel.

At any rate, the epca module will need to be removed (either the module or from the kernel).