Acceleport Xp Ubuntu driver

I have an 8-port Acceleport XP card and want to use it on an Ubuntu computer. I’m running Ubuntu 10.04 with kernel 2.6.32-28.

I tried installing both the source rpm and the tar ball 40002059_j buth they both failed compilation.
The first errors were:
/home/scms/rpmbuild/BUILD/dgdm-1.1/driver/triboot/tribl.h:89: error: redefinition of typedef ‘uintptr_t’
/home/scms/rpmbuild/BUILD/dgdm-1.1/driver/dgdm_driver.c:899: error: ‘SA_SHIRQ’ undeclared (first use in this function)

I then download the beta source rpm version and tried that. It failed compilation. The first error was
/home/scms/rpmbuild/BUILD/dgdm-1.1/driver/dgdm_tty.c: In function ‘dgdm_tty_init’:
/home/scms/rpmbuild/BUILD/dgdm-1.1/driver/dgdm_tty.c:627: error: ‘TTYDRIVER’ has no member named ‘refcount’

The date of the beta release is 12/02/2008 which is very old. Are there any plans to release a more up-to-date driver?


The last kernel version supported for this adapter is 2.6.25.

I recommend you contact your Digi Sales Representative to discuss this: 1-877-912-3444.