acceleport xem driver issue on ubuntu 8.04 64bit

Hello all,

I am trying to install the acceleport XEM onto my Ubuntu 64 bit 8.04 installation. I am stuck at getting the driver to install. I have been reading similar issues on the net and after trying many different thinks I ended up getting the latest driver, dgap-1.3-15 from I then tried to use alien to repackage it as a deb but it errored saying that amd64 is not supported. I found others with similar issues and I did the work around, alien -g and then edited the debian/control file and tried to dkpg -b the directory. If failed trying to go to a capitlized DEBIAN. I fixed that with a simple symbolic link. Then I got an error that the package name was empty. I removed an extra end of line character and then it dies at:
Depends’ field, invalid package name `${shlibs:Depends}': must start with an alphanumeric

I found someone else who said that $shlibs is a variable for the libraries and that unless the driver is written in c ( I think it’s written in Perl) then I can just delete it from the control file. I also had to add the Version: field but it does complete the .deb file. When I go to install the .deb file however I get this:

“root@salsafax:/home/tech2i# dpkg -i dgap-1.3.deb
(Reading database … 57900 files and directories currently installed.)
Preparing to replace dgap 1.3.15 (using dgap-1.3.deb) …
Unpacking replacement dgap …
dpkg: error processing dgap-1.3.deb (–install):
package control info rmdir of `dgap’ didn’t say not a dir: Directory not empty
Errors were encountered while processing:

This is where I am stuck. It seems like I have really gotten off the beaten path on this one. Am I taking the wrong approach here? Maybe I should just do an rpmbuild or something but I loathe the idea of 2 package managers. Any help is appreciated.

I think I might have solved my own issue. I went with the 1.3-15 driver which is beta based on someone elses recomendation before I figured out all the other workarounds I mentioned in my last post. When I do those same work arounds with the 1.3-6 driver it installs the .deb just fine.

Please also note that AccelePort Xem related questions should be posted in the corresponding forum section: