Accelport RAS offhook problem

I have an accelport RAS 4 port modem card demonstrating a problem. When a telephone line is connected to a port, after some time elapses, the port will latch in the ‘offhook’ mode. It only happens when a line is connected. In example, I can connect one line to one port today, come back tomorrow and that port is in the offhook mode. Unplug the telephone line from the ‘offhook’ port, plug into another port and it will work there for some time.

I have tried dm_admin to force a ‘hang up’ and to ‘cold reset’ the card, neither will work. The only way I have found to clear the port is through a reboot. I am using an mgetty to watch for connections. The mgetty is still running when the port locks up. Any suggestions?


This type of lockup problem is typically attributed to hardware conflicts on the PCI bus.

Not sure if you’re using Linux or not since it wasn’t mentioned, but I’m making an assumption that it is since you’re using mgetty. If yes to Linux, check /proc/interrups and /proc/pci for evidence of IRQ conflict.

We’ve also written an article about PCI contention:

I’m not positive that’s what the problem is, but the behavior you describe is typical of a conflict. If that doesn’t resolve it, make sure you’re using the latest driver from our website, and if still no go call Technical Support.

There is an IRQ conflict. I will attempt to resolve that.

We are using linux.


IRQ conflict was resolved. The card still has the same problem.

I noticed the Err entry in /proc/interrupts had a non-zero value and increased over time, whether the card was in use or not. As a test, the RAS card was removed and Err stayed at zero. When the card was re-installed, Err returned to an ever-increasing value.

The RAS card has version M2 firmware installed.



The only suggestion I have at this point is to call Technical Support for assistance. It might be a bad card or something, in which case you’d need to be setup for an RMA.