Ad-hoc mode on module

I am currently using a Wi-ME module with an access point.

If I disconnect the access point and configure an ad-hoc network, the Wi-ME fails to connect to it. I have ensured that the ad-hoc network has an SSID of ‘Connect’ and has encryption disabled.

Is there any particular trick to getting a Wi-ME to recognise an ad-hoc network?

You need to configure the wime if you want that it joins an ad-hoc network. By default, it create the ad-hoc network.

You should telnet on the wime, and write the command :
set wlan protmod=ibss_join

(This is what someone told me, however I can’t do it work fine)