after firmware update no connection

hi there,

I have found an old digi connect wi-me and would test it for new development project.

the old firmware was 82000977 and I downloaded the actual post and eos firmware. I uploading the new post firmware 82000980 and reboot the device, all fine. then I upload per webinterface the new eos 82000983. after many seconds the message appear that I must reboot.

after that the wi-me doesnt connect to any access point.

what can I do? I have not an jtag interface.

is there any way to reflash the digi connect over the serial interface or any other way?




And by saying “after that the wi-me doesnt connect to any access point.” have you tried all kind of AP’s??? i mean adhoc, infrastructure with encryption/key ???

Same problem here with my Digi Connect Wi-ME (not “C” version).

Using a Digi Connect ME dev board (30006002-02 rev A), I updated to latest POST firmware (82000941_J) & rebooted. Then I updated to latest EOS firmware (82000977_L) & rebooted once again.

After that, no more connections. Tried ad hoc (SSID “Connect”) as well as access point networks. Still no devices found in Digi Device Discovery application.

The link posted above is applicable only to “C” version modules so I didn’t try it.

Any other suggestions?


Just got my problem solved.

EOS firmware update did not reset network settings.

Moreover, using jumper P12 on eval board (according to instructions in another thread) to reset the Digi Connect to its factory settings did not fix the connection problem.

Fortunately, took me some time until device was listed in Device Discovery labeling “not properly configured”. With its IP address known, I could reset its network settings.