Digi Connect Wi-Me unreachable


I started testing a Digi Connect Wi-Me and it worked fine.

I wanted to configure the security parameters of the WPA (username and password) to test the security aspect of the product. Unfortunatly, I made a mistake with the parameters and reboot the Connect Wi-Me with it.

The fact is now the Wi-Me module is unreachable : the WIFI access point cannot reach the Connect Wi-Me.
I tested the WIFI access point and it works well, so the connexion problem comes with the Digi Connect Wi-Me.
I deleted the security level on the WiFi access point and it changed nothing.
I tried to reset the Digi Connect module several times to put back the factory defaults, but it changed nothing. (by the way, is anybody can confirm the fact that to restore the factory defaults I just have to do a hard reset by pushing the button SW3 on the evaluation board ?)
How can I clear the configuration and restore the factory defaults of the module ?

Despite the fact that the module is not recognised by the WIFI access point, the module starts normally and after a few second the two leds (the yellow and the green) start blinking.

  • The yellow one blinks every two seconds.
  • The green one blinks multiple times per second.
    What does it mean ?

I didn’t configure the RCI access (so I can’t configure the module using RCI), the TCP/IP access is disabled (unreachable using the WIFI Acces Point), so how can I take back control of the module ? How can I check the module configuration and modify it ?

I am quite lost, so if someone could help me, it would be really appreciated.

Thanks in advance.


May I assume that this is one of our Integration kit modules?

You do have a facility with which to reset the Wi-ME (or any Connect Integration kit unit back to factory defaults.

  1. On the development board, locate P12, and short out pins 2 & 3. With the EM, Wi-EM and SP press and hold the rest button on the unit itsefl, while power up.
  2. Power cycle the Wi-ME module and wait until the activity LED begins flashing in a 5-1-1 sequence.
  3. Remove the short on P12 and the Connect device should continue booting up normally and will now be using the factory defaults.



The pin 20 shortcut is the main way to reset the device back to factory defaults.

I believe you can also do it with a special back door recovery method using the serial port.

Sorry, posted too soon. You’ll need to run the attached procedure and run the following options:

  1. Erase NVRAM from flash. 2) Erase the BOOTPARM from flash.

Not quite. If you define a specifc SSID, the WiME will only associate with that SSID.

By default the SSID field is clear. That means it will prefer the SSID of ‘Connect’. Why it’s setup like this, I don’t know. It’s just the way it is.

But if you thereafter define an SSID other than the blank, it will only then associate with that SSID. Unless of course you factory default the unit, which will set the SSID field back to blank.

Since your WiME is already mounted, you can replicate the recovery procedure by grounding it’s pin 18; assuming you can. That’s the same as jumpering the MFG pins on the digi prototype board.



Thank you very much for this really quick answer.

I just tried it and it worked perfectly.
Thanks to you, everything is back to normal :).

P.S : I just checked in the hardware reference documentation and it is said something about the P12 jumper block and the soft reset. But, in my opinion, the explaination is really complicated not really clear.
Perhaps something to improve in a next version of the documentation ;).


I also made a mistake when i configurate my DIGI connect Wi-ME with WPA and now it is unreachable.

Is the shortcut on PIN 20 the only way to go back to default settings when the device is unreachable?
Is the DIGI Connect Wi-ME not supposed to connect to a “Connect” SSID?

thank you beforehand for your answers.



thanks for your answer.
But this procedure is if you are using the development board…
Here I have a digi WI-ME module already embedded on a device.

We thought that the DIGI WI-ME module will always connect to a “Connect” SSID even if a specific wifi network has been defined into the DIGI WI-ME configuration.
and it seems not, am I correct?


thank you for your answer.