ATA causes modem to try and dial out?

Trying to use DTMF routing for inbound faxes. For some reason the modem is getting confused and thinks it is trying to send a fax insead of receive. Basically, when the phone rings, the fax sofware is sending:

AT+FCLASS=8 (voice class)
AT+VLS=1 (go off hook)
ATA (this is wrong, but I can’t change it, and it shouldn’t hurt anything)


BUSY (duh, this won’t work, I called you!!!)

Any ideas?

Hello Ryan,
In the Hayes compatable command set, the “ATA” command is used to tell a modem to pick-up the line and begin training. In common modem trace you should see something like this (Excluding comments):

RING (Incoming call)
(Training is attempted)
CONNECTED 115200 (When training succeeds)


You are describing a data mode connection. There’s no such thing as training in voice mode.

What the program is really trying to do is just listen for DTMF tones. Since the modem is in voice mode (AT+FCLASS=8), ATA should be meaningless.

I’ve contacted the manufacturuer of the fax software to see if they can remove the extra ATA. But this is still a bug in the modem driver or firmware since the second ATA command should never cause the modem to dial out and think it’s trying to send a fax.

The AccelePort RAS modems are data only. The modems do NOT support Class 1 faxing nor do they support any voice commands, so please configure your fax program (whichever one you are using) to exclude class 1 faxing. The AT commands you are reporting are not supprted by these modems. It appears that the correct modem type may not selected by the fax program, or, possibly, the fax program only supports a specific modem or two. The AccelePort RAS modems are based on the Rockwell 56k chipset and most AT commands which work for Rockwell chippset based modems work on these modems as well. For details, please see the AT Command Reference at this link:

Ryan, the AccelePort RAS cards support FAX class 2 and 2.0. If this is an option in your fax program, try selecting class 2 or 2.0 and see what type of behavior you get.

We do not support fclass=1, so I’m not sure what would have happened when the program attempted to set that. The commands may have been misinterpreted at that point or the modem may have reverted to some other fax class or it may have just given OK as a dummy response to an invalid command.

Please try fclass=2 or 2.0 and see what the results are.

Thanks for the suggestion, but I get the same result.

I was able to get the Fax software vendor to remove the extra ATA and it’s working fine now. If you can reproduce the bug it might be something worth fixing in a future firmware.


Thanks for the update Ryan, its useful info and might be worthy of a knowledge base article, but which fax vender/software and version is this?

I didn’t see that listed earlier in this thread, so if I’ve overlooked it I apologize.