Bricked Xbee3 ?


I have a Xbee3 board which is running a micropython script which is printing on the serial console in a “while true” loop. I am trying to make it detectable by the XCTU program but seems that it can’t, the transmit led is always on …, looks like the XCTU doesn’t have a chance to talk to it before the micropython script is loaded and started. Also tried the recovery feature, didn’t work. The xbee is connected through a FTDI USB-UART converter with CTS DTR lines connected. Any suggestion for this problem ? I was wondering if I can program the xbee bootloader using the JTAG interface, couldn’t find anything related to it though.


No, but you can use remote AT commands from a remote XBee that is in API mode. This would allow you to send a remote AT command to turn off the auto start for Micro Python and resolve that issue. The other option is to force command mode by holding DI low and power up the module. Then issue the desired AT command to turn off Micro Python or turn off the auto python start.

Thanks, it worked flawlessly.