CM-8 will not save changes to config or f/w

I have a CM-8 running f/w v1.6.5 that will not save any configuration changes or firmware upgrades. Every config change I attempt responds with “Failed to save changes” regardless if I use save_to_flash or save_and_apply. Apply_changes always responds “there is nothing to be applied.” Config changes are never persistent across reboot.

Firmware upgrade attempts always report success, but on reboot it reverts to 1.6.5 and the default config values.

Tried replacing the battery, but that had no effect either.



Sounds like corrupted memory. Try running thru the ‘Disaster recovery’ steps noted in the CM User’s Guide or here:

the plot thickens… web mgmt works, but serial console mgmt is unresponsive. Tried factory reset button several times, no luck.

I am able to get it to load f/w via the web, reports success but it doesn’t show the new rev afterward.

Is there any way to get it to force reload firmware from a flash card?

Another way to hard reset other than the factory reset switch?

Just to be sure my mgmt console cabling is good for the CM8, can someone please verify this is the correct pinout?