Configuring Issues

I have bought a XBee series 2 modem…I’m trying to configure the modem using the X-CTU software which i downloaded from this site but i cannot configure it…each time i press the test/query button I get the following error…

Communication with modem : OK
Modem Type = Name unknown (ID= 429496…)
Modem Firmware version = ATVR

Serial No = ATSH

I have gone through most of the discussion in this support forum regarding similar problems and i have tried out all possible solution but nothing seems to work…i have updated the firmware version also tried the reset switch but nothing seems to help…when i go to modem configuration and select the modem and press the read button i get a pop-up window stating " unable to communicate with the modem and it ask me the hold the reset switch for 10 secs which i do but nothing works…
Could some one please help me out with this


Check the COM port and Baud rate settings under PC Settings, try to re-flash the firmware of the XBee module.
Refer the following link, and and see if this solves your issue.