HELP needed to configure xbee modules

Hello! I have 2 xbee modules, series 1…and I have a lot of problems with them… I try to use button Test/Query using X-CTU software (PC settings tab), but I always get the same answare: Unable to communicate with modem… (I had one time answer with modem and firmware version, but that was just for one time, and I can’t remember what I done to get this response…).
Unfortunately, I have the same problem with both xbee modules… I tried to rewrite modem (Modem:XB24, Version:10A5, I checked “Always update firmware”), but without success… I always get the same response:" Getting modem type…OK
Programming modem…Lost communication with modem
Write parameters …Failed"
I tried to use another verisons,too…
I use development board with RS232 connection…
What am I doing wrong???


Have a look in the 802.15.4 forum, and check the pinned posts at the top. You’ll find a reference to my Unofficial FAQ, which contains some hints about things to try when X-CTU says it can’t communicate.

You’ll want to update your firmware to the latest version, which at the time of writing is 10E6.

Let us know how you get on…

Have you tried using serial settings 9600 8n1 hardware flow control? You would set this under the PC settings tab.

yess… I set that value for baudrate, 8n1 none flow control, and I also tried to change these values…

Better yet I’ll just move this as a new thread to the 802.15.4 forum :wink:

I’d recommend hardware flow control as well.

:smiley: Oky… I’ll try…