Connect EZ 4 to Juniper EX4300 Console

Just received an EZ 4, was able to get it online and then connected ports 1 to 4 to the console ports on a Juniper EX4300 VC that I have. It DOS’d the switch somehow with bad login attempts. Was very odd. I had to reboot the VC to get it back online. So I did some more research and determined I perhaps had to build the custom cable as mentioned on the last page of this document:

I’m now testing on my lab VC in the event this crashes it again. So far I only have one console port connected and I’m not seeing the same issue.

I built a custom cable per Digi pin out diagrams, and I now show RTS CTS DTR DSR, but no signal when I attempt console access. I have also tried flipping the RTS Toggle with this special cable and a normal ethernet cable. I normally console into my junipers with a straight ethernet connected to one of their RJ45 to DB9 converters, connected to a USB serial port.

I’m surprised Digi doesn’t have guides for Juniper, Cisco, etc regarding needed cables and proper settings, would save a lot of time. I can’t believe I’m the only person who has tried to use one of these devices as remote console to a Juniper switch.

I know Juniper sells a custom cable (76000631 - 6' cable RJ-45 to RJ-45 for Sun Netra/Cisco | Digi International) but I’ve built 100s over the years and I made one this AM to no avail. Possible I didn’t do so properly I guess. Anyway, if someone has one of these devices connected to a Cisco or Juniper switch and would be willing to share their cable/port settings I’d appreciate it.