ConnectCore9P Serial Port C


Has anyone done any work with the ConnectCore9P serial port C?

I have tried to get this going with;

With this setting the serial port does not operate. Further investigation shows that the required GPIO multiplexor settings do not get set correctly.

Putting some code in to directly configure the GPIO configuration registers in the processor does allow the port to work correctly. Is this a problem with the API or am I missing a vital setting in one of the bsp header files?


I have now done a bit more work on this. If I run the application under the debugger the port gets configured correctly. If I put it into flash, it does not configure the GPIO pins for serial port operation.


Have tried the release build, and it wound up crashing.

I finally, generated a New Project app in ESP, updated the BSP header files to be the same as the ones needed in my main app, and used the bootloader generated from that. This gets things working.

I need to do some more checking of exactly what is happening in the bootloader of my main app. Are there any hints anywhere on the best process to use for debugging the bootlader?

When running from the debugger, the GPIO’s get configured by the application image (image.elf) when it first starts up. When running from flash, it get’s configured from the boot loader (rom.bin). So, build a release image for your project and update the boot loader and it should work just fine.