could not determine operating mode

I cannot find a solution to this problem. My XBee 900HP digimesh was working perfectly in AP (1) mode (as coordinator). Now it no longer works, my python3 code has not changed. If I connect to XCTU it appears to be working and receives data from the routers as expected.

I pulled a snip of the code that used to work. I have it running on a Raspberry PI 3. Again everything was working.

import serial
from digi.xbee.devices import XbeeDevice
device = XBeeDevice(“/dev/ttyS0”, 9600)

Once the open line is executed I get the following error:

Traceback (most recent call last):
File “”, line 1, in
File “/home/pi/.local/lib/python3.7/site-packages/digi/x
bee/”, line 2043, in open
File “/home/pi/.local/lib/python3.7/site-packages/digi/x
bee/”, line 2059, in _do_open
Raise InvalidOperatingModeException(message=“Could not
determine operating mode”)
digi.xbee.exception.InvalidOeratingModeException: Could n
ot determine operating mode

…Again, this used to work and I am completely baffled.

Any help would be greatly appreciated. If I need to supply more detail please let me know and I
can send screen shots and pictures.

Thank you,


That is not something that would be answered on this forum but on a forum for the processor and its related code.

my python3 code has now not changed. If I join to XCTU it seems to be working and receives facts from the routers as expected.

Hello wrwygal,
I 've got the same problem. The same error with an unchanged code that worked before. I tried to change the raspberry without success. Did you finally found a solution ?
Thank you