DC 9.52 Hangs, Frustrating!

I’m trying to do a development project with the RM3700 and Dynamic C 9.52.

My problem is that the IDE hangs all the time. Seems to happen most when I edit a source file and save it. It will usually hang on the save or when I click RUN to start a new recompile.

I’ve tried just about everything and are at wits end. I don’t think its a serial port issue, because it happens when using a real COM port as well as a USB/serial adapter. I’ve tried disabling all other programs and non-essential services like anti-virus, etc., still no luck.

I’ve got to believe that its something in my machine that is causing this, unless the DC software is just unstable to begin with. I have no problems whatsoever with my machine running any other software.

If anyone out there has experienced hangs and crashes with DC, I would appreciate any comments and help. I already emailed rabbit tech support and their answer was “doesn’t happen here, you must be doing something wrong”.

Good afternoon,
Not all USB cables communicate with Rabbit products, are you using one that we recommend? Have you re-installed the software? What other applications do you have running? WHat operating system do you have?

Thanks Margaret for the private message follow-ups and solving my problem.

The problem was caused by the dual-core processor in my machine (running XP). After installing the Microsoft XP dual-core fix (http://support.microsoft.com/kb/896256) and the Affinity single CPU app you sent me, all my problems are solved.

It’s nice to know that Rabbit Tech support does stand behind their products and supports both hardware and software issues in a timely manner.

Thanks again,

  • Joe

It seems like I’m having the same problem. I’ve just installed the MS XP dual-core fix.

I’m curious on the “Affinity single CPU”, where to find it?

There is a Technote 257 that contains the affinity application. Go to Rabbit.com, look under Support and you will find Tec notes.
I hope this helps!

Thanks Margaret!