Device disassociated after long sleep time

Hello everyone,

I am facing a problem using the XBEE DigiMesh modules. My project consists in several sensor nodes configured as end devices. in each node there is an MCU that handles all the sleep timing (>1min) and sensor data acquisition. Therefore, there are several times that when I wake the XBEE module up, it gives a ‘Device disassociated’ status preventing me from sending data.

I have already managed a fix for it, which is to always for a reset (AT Command ‘FR’) and then waits for a ‘Device joined network’ modem status, only after that I send the sensor data to the coordinator.

Even it is working so far, as I reset the module, it takes a while to reconnect to the PAN and then waste battery, which is a limited resource.

How can I ensure that, whenever I wakeup the XBEE, it always ramains connected to the same PAN?

ps.: I am using the API mode

ps2: I have already tried to request the association indicator command ‘AI’ to the module, but sometimes it returns ‘OK’ and then the module sends a ‘Device disassociated’, causing loss of data.

Any help will be greatly appreciated.

What is the full part number and firmware version of the radio you are using?

What settings are you using on the radio?

Hi mvut,

follow the information you asked. I hope everything is here.

The PN is: 1846A-S2CTHXB24CZ7PIT-004-revC
model: S2CTH

Firmware Version: 4059
Hardware Version: 2E43

The module settings:
SC: 7FFF SD: 3
ZS: 0 NJ: FF
NW: 0 JV: 0
JN: 0 CE: 0
DO: 0 DC: 0

DH/DL: 0 NH: 1E
BH: 0 AR: FF
DD: A0000 NT: 3C
NO: 0 CR: 3

SE: 3E8 DE: E8
CI: 11 TO: 0

PL: Highest [4] PM: Boost Mode Enabled [1]

EE: Disabled [0] EO: 0

BD: 57600 [6] NB: No Parity [0]
SB: One Stop Bit [0] RO: 3
D7/D6: Disable [0] AP: API Enabled [1]
AO: Native [0]

CT: 64 GT: 3E8
CC: 2B

SP: 358 SN: 1
SM: Pin Hibernate [1] ST: A

D0: Comissioning Button [1]
D5: Associate indicator [1]
D8: Sleep RQ [1]
D9: Awake/Sleep Indicator [1]
P0: RSSI PWM Output [1]
All other I/Os: Disable [0]
LT: 0
RP: 28

IR/IC/V+: 0

The reason you are having these issues is because you are using Pin sleep and you are sleeping for longer than twice the SP time frame on your parent router/coordinator. To resolve this, set the SP time so that it exceeds the maximum sleep time you are using on your Pin sleep end device.

Hi Nicolas,

same issue we are facing that u mentioned. your help is appreciated. we have installed total 300 end devices with routers and co-ordinators in networks. some end devices are not re-associated after wakeup time for 5 min. but my SP is not 5 min. in co-ordinator. problem is, some time this end devices are not sending data for more then 1 day. and suddenly after this time this will start sending again. for every 5 min. so data loss occur in trend on customer place.